Why am I seeing a MethodNotAllowedError message?

When installing Spanning Backup for Salesforce, if you receive the following error message, your Spanning install is not properly configured:

{"code":"MethodNotAllowedError","message":"GET is not allowed"}

This error means that the Connected App has not been set to "Admin Approved users are pre-authorized".  To set this up, follow these steps:

1. As a Salesforce admin user click Setup

2. In the left sidebar under Administration Setup, go to Manage Apps > Connected Apps

3. Click Edit next to SpanningBackup

4. Under OAuth Policies, make sure Permitted Users is set to "Admin Approved users are pre-authorized"

5. Click Save

6. Click Edit next to SpanningRestore

7. Under OAuth Policies, make sure Permitted Users is set to "Admin Approved users are pre-authorized"

8. Click Save

Click Spanning Backup for Salesforce Manual for the full Spanning Backup for Salesforce install and setup guide.


 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us